We have detected that cookies are not enabled on your browser. Please enable cookies to ensure the proper experience.
Page 2 of 2 FirstFirst 1 2
Results 26 to 30 of 30
  1. #26
    Join Date
    Mar 2007

    Lotro plugin compendium and Crossover

    When I tried to run the Setup.exe file from LoTRO Plugin Compendium in the Lotro bottle, I got the following message:

    Setup has detected that the file C/usersicrossover \TempiN5D6e93, tmpiDotNetFX472\NDP472-
    KB4054531-Web.exel has changed since it was initially published. Click ok to retry the download, or Cancel to exit setup.[/QUOTE]

    Does anyone know whether this is a "normal" message and whether I should click OK to retry or did I do something wrong?
    Thank you for any and all help.
    "I am a servant of the Secret Fire, wielder of the flame of Anor. The dark fire will not avail you here, flame of Udûn. You cannot pass."

  2. #27
    Join Date
    Mar 2007
    Quote Originally Posted by Tralfazz View Post
    I do not use Plugin Compendium. However, the key to getting any pair of applications to work together in Crossover is to install them both into the same bottle. Normally you want every Windows application to be installed into its own bottle; this is one of the exceptions to that rule. So be sure that Plugin Compendium is installed in the same bottle as LOTRO. If not, delete the other bottle then install Plugin Compendium into your LOTRO bottle.

    I have no idea why the Plugin Compendium application would run a Star Wars file.

    There are fellow LOTRO forum users successfully running the Windows version of the Plugin Compendium application in Crossover, perhaps one of them will be able to help you.

    There is a Java version of the Plugin Compendium which runs natively in MacOS. Well, it runs in Java which is a virtual machine – but outside of Crossover, anyway. It works, people are using it today. Here is the link:
    You will need to install Java first:

    edit: Had to remove the direct download links for Java. You'll need to go to the page I linked and choose the MacOS tab then download the jdk-8u371-macosx-x64.dmg file.

    thank you. Once I install Java and then the Java version of the Plugin Compendium, how do I get it to run in Lotro given that it is outside of Crossover?
    Thank you again.
    "I am a servant of the Secret Fire, wielder of the flame of Anor. The dark fire will not avail you here, flame of Udûn. You cannot pass."

  3. #28
    Join Date
    Jul 2020
    Quote Originally Posted by Mythrandir View Post
    Once I install Java and then the Java version of the Plugin Compendium, how do I get it to run in Lotro given that it is outside of Crossover?
    The Plug-in Compendium only deals with files inside your ~/Documents/The Lord of the Rings Online/Plugins folder, it doesn’t interact with the game’s files or communicate with the running game client application in any way. Again, I have never used Plugin Compendium but I would guess that it either knows the path to your Plugins folder or there is a configuration option where you can enter it.

    I don’t use Plugin Compendium because it is extremely easy to install plugins manually. I keep all the plugins I’m interested in on my lotrointerface.com favorites list so all I have to do is check lotrointerface.com every now and then and if my favorites list there says something was updated I just download and install it to replace the old version in my Plugins folder.

    I’ll check out the Java version of Plugin Compendium right now and assuming I can get it to work I’ll give you instructions to use it in the next message.

  4. #29
    Join Date
    Jul 2020
    Alright, well, that was extremely fast and easy. The Java version of the Plugin Compendium works fine and is easy to download, install, configure, and use. Here's what you do:

    1- Download and install Java 8 for Mac. Here's the link again:

    2- Download the Java version of Plugin Compendium for Java 8. There are two, one for Java 8 and one for Java 11. YOU MUST DOWNLOAD THE ONE FOR JAVA 8:

    3- In your ~/Downloads folder or wherever your web browser drops downloaded files you will find a folder named:
    Open that folder, inside is a folder named:
    Open that folder, inside is a Mac application called PluginCompendium.

    4- You can move the PluginCompendium application to your /Applications folder if you want to, but it doesn't care where it is. Put it anywhere you want, leave it where it is, whatever.

    5- Double-click the PluginCompendium application. This will run the application inside the Java environment. It will look more like a crude Windows application than a pretty Mac application, but it works.

    6- Your Mac might complain that it can't verify PluginCompendium and that there are security risks blah-blah-blah. Close any dialogues complaining to you and then launch PluginCompendium by right-clicking it and choosing OPEN. Your Mac will complain again but it will give you the option to OPEN ANYWAY or something similar. You will only have to do this once, you can double-click it for all subsequent launches.

    7- The first thing that you'll see when you run PluginCompendium for the first time is a dialogue asking you to find your Plugins folder. Using the Finder, go to your ~/Documents/The Lord of the Rings Online folder and if you don't have a Plugins folder in there, create it. The full path should be:
    ~/Documents/The Lord of the Rings Online/Plugins

    8- You can then click on the INSTALLED PLUGINS tab and it will show you all the plugins you already have installed. Or you can click on ADD NEW PLUGINS if you want to install a plugin you don't already have.

    9- When you're done, quit out of the PluginCompendium application using COMMAND-Q.

    10- I assume the main point of PluginCompendium is that it will automatically update any already-installed plugins when you click the UPDATE button. I did not test this feature.

    That's it, pretty easy. But installing and updating plugins manually by just downloading from lotrointerface.com and dropping the files and folders into the right place yourself isn't any harder. But to each their own! If you like using the PluginCompendium application, well, it works, so there you go.

  5. #30
    Join Date
    Jun 2011
    Quote Originally Posted by bilgamesh View Post
    I updated my M1 Mac mini to Mac OS Ventura 13.3 this morning. Since then, I've been unable to get past the LoTRO launcher*. I'm using Crossover Mac 22.1. Before the OS update LoTRO worked reliably. I can patch, login then hit "Play" and the launcher closes and nothing else happens visually. From the terminal can see that lotroclient64.exe is running along with several windows helper programs. I also see 0 byte lotroclient64_d3d10.log and lotroclient64_d3d11.log are created (config set to DX11). "The Lord of the Rings Online" has microphone permissions (reading the prior thread).

    *I did get it to launch once without changing anything....which is rather annoying. I then rebooted the machine before trying again and was unable to get it to start after a dozen or so attempts. The one time it did launch, I was also able to launch another game that stopped working (Guild Wars 2).

    If anyone has any suggestions, I'd love to hear. I've also opened a ticket with Codeweaver's Crossover support team.

    Apart from your questions ;-)

    I have some questions about your Mac Mini M1 setup.

    - What configuration of Mac mini do you have?
    - how is the performance of Lotro under crossover?

    I will upgrade to a Mac Mini M2 or M2 Pro and hope it will work better than with my old Windows desktop (RX480, Intel i5 4570, 16GB RAM).

    If anyone else has some information for me, it would be my pleasure
    ::: GWAHIR ::: ::: Waechter der Klamm ::: Kraatos | Warden | 120 ::: Grimnirr | Champion | 120 ::: Tasatir | Hunter | 120 ::: Shamroc | Rune-Keeper | 120 ::: Niike | Minstrel | 120 ::: Balflear | Burglar | 115 :::


Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

This form's session has expired. You need to reload the page.