Is there a Setting I can change to turn off the constant Dust cloud around Hrímil at the end of Hiddenhoard? I do not recall having the issue until I recently reset my Gfx Settings in game.

It causes me a lot of graphical lag during the fight.

Thanks for your time.