Wir haben festgestellt, dass Euer Browser keine Cookies akzeptiert. Bitte erlaubt die Verwendung von Cookies in den Optionen Eures Browsers, um eine optimale Funktion dieser Webseite zu gewährleisten.
Ergebnis 1 bis 25 von 40


  1. #1
    Registriert seit

    Tralfazz, help! Homebrew installation gone wrong!

    I followed the instructions of your Jan.02 2022 post. Some differences cropped up during the installation of Homebrew, but I assumed these had been due to updates and continued. Specifically, the principle changes were:
    1. I was not asked if I want to install the Xcode command-line tools; it went ahead and installed them, as far as I could tell, anyway. When I (rather blindly) followed the original instructions and typed YES anyway, Terminal went nuts and started typing an endless column of ‘y’s. After a bit I turned Terminal off and repeated the procedure, without typing YES this time.
    2. The process ran for a long time by itself. I did not get a chance to input “brew install wine-stable”, because at one point Terminal typed “Downloading and installing Homebrew…” and apparently proceeded to do just that. This might be were I went wrong, but I’m not clear what if anything I could have done.

    At the end, I typed in “brew doctor” but the only response was:

    iMac:~ jcs$ brew doctor
    Please note that these warnings are just used to help the Homebrew maintainers
    with debugging if you file an issue. If everything you use Homebrew for is
    working fine: please don't worry or file an issue; just ignore this. Thanks!

    Warning: You are using macOS 10.13.
    We (and Apple) do not provide support for this old version.

    You will encounter build failures with some formulae.
    Please create pull requests instead of asking for help on Homebrew's GitHub, Twitter or any other official channels. You are responsible for resolvingany issues you experience while you are running this old version.

    So I assumed all was OK.

    I then dragged the file LotroLauncher.exe to the right side of the dock. Unfortunately, instead of launching the game, clicking on it simply produces a new version of the LotroLauncher folder in the Lord of the Rings Online folder. Weird.

    I next tried to launch the game by clicking on the old lotroclient icon. This took me through all the stages of launching the game including the familiar error messages (DDLfiles are missing) and (installer error: 16389 and DLL files are missing). At the very last screen, selecting a world, once a world is selected, the message “getting in line” flashes very briefly, and then nothing more happens.

    Now stuck and in need of assistance!
    Many thanks in advance.

    PS: I should add that this is all happening on an iMac running High Sierra 10.13.6 which cannot be upgraded further, but I remember Tralfazz assuring me that the procedure should still work!
    Geändert von Anaxapart (13.06.2022 um 10:55 Uhr)

  2. #2
    Registriert seit
    Somewhere along the way, you skipped a step or didn't wait for a process to finish. It's very difficult to tell exactly what happened based on your report, but I think that after you installed Homebrew you didn't use it to install WINE. The only reason we install Homebrew is to use it as an easy way to install WINE.

    If that's the case, if you skipped the step for installing WINE, this is going to be an easy fix. But even if it's something else, don't worry, we'll get you fixed up.

    We are going to follow the procedure in this thread:

    We'll do everything one step at a time, confirm that step was completed successfully, and then we'll move on.

    A- The first thing to do is to confirm that you have SSG's "Mac Download" installed on your computer. It should be here:
    ~/Library/Application Support/com.standingstonegames.lotro
    Based on your OP, that seems to be in place. So we'll move on to the next step.

    B- Let's check your MacOS installation:
    1- Go to the Mac App Store. Go to Updates. Install any updates.
    2- Go to System Preferences->Software Update. Install any updates to MacOS 10.13 High Sierra.

    C- I think you have Homebrew installed, but let's double-check:
    1- Launch the Terminal.
    2- Enter this command:
    brew doctor
    You don't have to report in great detail about the output of this command. If it tells you there's a serious problem other than the need to update your command-line tools (which you can safely ignore), report that. Otherwise, just move on to Step 3.
    3- Once you see the command-line prompt, which means the previous command execution is complete, enter this command:
    brew update
    4- Once you see the command-line prompt, which means the previous command execution is complete, enter this command, again:
    brew doctor
    D- This is the part that I think you skipped:
    1- Enter this command into the Terminal:
    brew install wine-stable
    2- HAVE PATIENCE. Enter your password if requested, remember to hit the RETURN key after entering your password. Then WAIT, allow the install to fully complete.
    3- When you see the command-line prompt, that means Homebrew has finished installing WINE for you. Enter this command:
    brew doctor
    4- When you see the command-line prompt again, enter this command:
    brew update
    5- When you see the command-line prompt again, enter this command, again:
    brew doctor
    6- Report anything that you think might be unusual or that you think went wrong during this process.

    At this point you can either STOP HERE and report back and then wait for additional instructions customized for you. Or you can proceed with the procedure in https://forums.lotro.com/forums/show...pler-procedure, Step E.
    Geändert von Tralfazz (13.06.2022 um 11:35 Uhr) Grund: removed a spurious period

  3. #3
    Registriert seit
    I just want to add that nothing about the procedure in this thread...
    ...makes any changes to your "Mac Download" version of the game (i.e. the Windows version of LOTRO) or the old version of WINE associated with it. All the procedure in that thread does is install a more modern version of WINE, the latest wine-stable, and then run the Windows version of LOTRO which is already installed by the "Mac Download" version of the game.

    So nothing that is done in the procedure outlined in that thread should have any effect on your ability to run the "Mac Download" version of LOTRO. It is possible to run LOTRO using both versions of WINE (but not simultaneously), the WINE bottle associated with the "Mac Download" is not changed in any way and the installation of the Windows version of LOTRO is not changed in any way except by LOTRO's own patching mechanisms.
    Geändert von Tralfazz (13.06.2022 um 11:43 Uhr) Grund: clarified multiple versions of WINE, not multiple versions of LOTRO

  4. #4
    Registriert seit
    Many thanks, Tralfazz.

    Just completed a 2.5 GB OS update, now installing wine-stable.
    I'll report back when it's all done!

  5. #5
    Registriert seit
    OK, steps 1-6 completed:
    ???? wine-stable was successfully installed!

  6. #6
    Registriert seit
    Continuing with steps E and F, I am still having trouble launching with "LotroLauncher.exe". What it seems to do when clicked on is briefly open and activate the Kekka application, which is a file decompression utility (!). Baffling...

    So, trying again to launch the game via the old lotro client, the same result as reported earlier: after choosing a world, you get the text message "getting in line to connect" flashing by, then nothing.

    Here btw is the principal Terminal feedback for the installation of wine-stable:

    ==> Downloading https://github.com/Gcenx/macOS_Wine_...wnload/7.0/win
    ==> Downloading from https://objects.githubusercontent.co...uction-release
    ############################## ############################## ############ 100.0%
    ==> Installing Cask wine-stable
    ==> Moving App 'Wine Stable.app' to '/Applications/Wine Stable.app'
    ==> Linking Binary 'appdb' to '/usr/local/bin/appdb'
    ==> Linking Binary 'winehelp' to '/usr/local/bin/winehelp'
    ==> Linking Binary 'msiexec' to '/usr/local/bin/msiexec'
    ==> Linking Binary 'notepad' to '/usr/local/bin/notepad'
    ==> Linking Binary 'regedit' to '/usr/local/bin/regedit'
    ==> Linking Binary 'regsvr32' to '/usr/local/bin/regsvr32'
    ==> Linking Binary 'wine' to '/usr/local/bin/wine'
    ==> Linking Binary 'wine64' to '/usr/local/bin/wine64'
    ==> Linking Binary 'wineboot' to '/usr/local/bin/wineboot'
    ==> Linking Binary 'winecfg' to '/usr/local/bin/winecfg'
    ==> Linking Binary 'wineconsole' to '/usr/local/bin/wineconsole'
    ==> Linking Binary 'winedbg' to '/usr/local/bin/winedbg'
    ==> Linking Binary 'winefile' to '/usr/local/bin/winefile'
    ==> Linking Binary 'winemine' to '/usr/local/bin/winemine'
    ==> Linking Binary 'winepath' to '/usr/local/bin/winepath'
    ==> Linking Binary 'wineserver' to '/usr/local/bin/wineserver'
    ???? wine-stable was successfully installed!
    Geändert von Anaxapart (13.06.2022 um 13:20 Uhr)




  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein

Diese Formular-Sitzung ist abgelaufen. Du musst die Seite neu laden.

Neu laden